Data View Web Part – Not Working SharePoint 2013

Hi guys,

This is a little bit like deja vu.

I created a new Data List View for a document library I wanted to display to all of the users. However, I received an error that looks like this (click to enlarge) –


I somehow had a little part inside my head telling me I had faced an issue like this before back in SharePoint 2010 – except it had another unhelpful error in the form of a Javascript error. I followed my blog post (some of it) to get this to work again.

  1. In SharePoint Designer, open up the .aspx page that contains the faulty Data List View.
  2. Click on ‘List and Libraries’ where you have created the Document Library you are trying to view with the Data List Viewer.
  3. Open up ‘All Documents’
  4. There will be a tag called ‘WebPartPages:XsltListViewWebPart‘. In here is a property called ‘ViewGuid‘ (Click to enlarge the image!)
  5. Copy the ‘ViewGuid’ property and what it is setting
  6. Go back to your page and where your web part starts (WebPartPages:XsltListViewWebPart), add this property just after that.
  7. Save and reload your page and your library should appear!

However, if you do have any problems, feel free to post a comment. 🙂

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s